Custom Planet, interfaces have no IP address?

I have a custom planet definition up and working, and a working network using ztncui. However every time a node joins the network, it fails to create any IP addresses on the interface:

zt003mlam78kv04: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 5000 mtu 2800
        ether 06:7c:84:5b:00:5b
        hwaddr 58:9c:fc:10:ff:99
        inet6 fe80::5a9c:fcff:fe10:ff99%zt003mlam78kv04 prefixlen 64 scopeid 0x5
        groups: tap
        media: Ethernet autoselect
        status: active
        nd6 options=21<PERFORMNUD,AUTO_LINKLOCAL>
        Opened by PID 69325

This happens for all nodes, but what is even weirder is that the address seems to work!!

% ping                                                           17:42:57
PING ( 56 data bytes
64 bytes from icmp_seq=0 ttl=51 time=38.257 ms

even though that device is nowhere in my ifconfig???
I’ve run through all the logs, cannot find any errors:

Jan  9 12:39:10 valkyrie-09 zerotier[13490]: zt003mlam78kv04
Jan  9 15:31:44 valkyrie-09 zerotier[68647]: zt003mlam78kv04

System is FreeBSD 12, anyone see what’s wrong here?

Have you authorized the nodes in ZTNCUI?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.