Help I have a serious problem with the ZeroTier program

Hello everybody, I having at the beginning the ZeroTier version 1.8.8 program, which worked, it happened to me that automatically without asking me anything it updated to the latest version 1.8.10 and from there on nothing works anymore, I tried everything and I am desperate to restart it for personal use, my companions have version 1.8.8 but I don’t think it’s their problem, to me every time I open the program I am alone at the bottom right on the program icon waiting for ZeroTier system service, by checking on my pc the ZeroTier card that I had configured as in the tutorial at the end of this page also disappeared on the network cards https://support.parsec.app/hc/en-us/articles/115002766652
what can i do to completely fix the problem? (to my friends version 1.8.8 still works)

Hello
ZeroTier doesn’t do automatic updates, so I don’t know how that happened.
You could try re-running the installer from Download – ZeroTier

tnx,as I have already written I have already tried and it did not help

I had this happen to me sometimes, mainly when formatting and reinstalling Zerotier, thing is Zerotier doesn’t work well anymore when you backup the Zerotier folders from ProgramData and AppData, so deleting those worked. This will delete all the configuration but I say try deleting this two directories:
“C:\ProgramData\ZeroTier” and “C:\Users\angel\AppData\Local\ZeroTier”
Then reinstall.

I did it, on the page where I am subscribed to ZeroTier it tells me that I still have version 1.8.10, consequently I would like to understand why it says so, the program created 4 folders scattered around the computer, and I deleted them ( so which version should i download and install ?, so how can i undo that it updates itself as soon as i install it? )