I'm on Mint 20.3 but getting error messages: "Some packages can't be installed" ... "unmet dependencies"... "package installation failed"

I’m on Linux Mint 20.3 Cinnamon. Can someone please help.
I run

~$ curl -s https://install.zerotier.com | sudo bash
[sudo] password for me: 
    

*** ZeroTier Service Quick Install for Unix-like Systems

*** Tested OSes / distributions:

***   MacOS (10.13+) (just installs ZeroTier One.pkg)
***   Debian Linux (7+)
***   RedHat/CentOS Linux (6+)
***   Fedora Linux (16+)
***   SuSE Linux (12+)
***   Mint Linux (18+)

*** Supported architectures vary by OS / distribution. We try to support
*** every system architecture supported by the target.

*** Please report problems to contact@zerotier.com and we will try to fix.

*** Detecting Linux Distribution

*** Found Linux Mint, creating /etc/apt/sources.list.d/zerotier.list
OK

*** Installing zerotier-one package...
Ign:1 http://dl.google.com/linux/chrome-remote-desktop/deb stable InRelease
Hit:2 http://dl.google.com/linux/chrome/deb stable InRelease                   
Hit:3 https://deb.opera.com/opera-stable stable InRelease                      
Get:4 https://dl.winehq.org/wine-builds/ubuntu focal InRelease [8,041 B]       
Hit:5 https://brave-browser-apt-release.s3.brave.com stable InRelease          
Get:6 http://download.zerotier.com/debian/xenial xenial InRelease [17.3 kB]    
Hit:7 http://dl.google.com/linux/chrome-remote-desktop/deb stable Release      
Get:8 http://security.ubuntu.com/ubuntu focal-security InRelease [114 kB]      
Hit:9 http://packages.microsoft.com/repos/edge stable InRelease                
Hit:10 http://apt.insync.io/mint ulyssa InRelease                              
Hit:11 https://packages.microsoft.com/repos/ms-teams stable InRelease          
Ign:12 http://repo.vivaldi.com/stable/deb stable InRelease                     
Hit:13 http://repo.vivaldi.com/stable/deb stable Release                       
Ign:14 http://packages.linuxmint.com una InRelease                             
Hit:15 http://ppa.launchpad.net/alessandro-strada/ppa/ubuntu focal InRelease   
Hit:16 http://packages.linuxmint.com una Release                               
Hit:17 http://archive.ubuntu.com/ubuntu focal InRelease                        
Get:18 http://archive.ubuntu.com/ubuntu focal-updates InRelease [114 kB]       
Get:19 https://dl.winehq.org/wine-builds/ubuntu focal/main i386 Packages [323 kB]
Hit:20 http://archive.canonical.com/ubuntu focal InRelease                     
Hit:21 http://ppa.launchpad.net/audio-recorder/ppa/ubuntu focal InRelease      
Get:22 https://dl.winehq.org/wine-builds/ubuntu focal/main amd64 Packages [322 kB]
Get:23 http://download.zerotier.com/debian/xenial xenial/main amd64 Packages [5,085 B]
Hit:25 http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal InRelease      
Get:26 http://download.zerotier.com/debian/xenial xenial/main i386 Packages [5,048 B]
Ign:27 https://mkvtoolnix.download/ubuntu bionic InRelease                     
Get:28 http://archive.ubuntu.com/ubuntu focal-backports InRelease [108 kB]
Get:29 https://mkvtoolnix.download/ubuntu bionic Release [6,597 B]
Get:31 https://mkvtoolnix.download/ubuntu bionic Release.gpg [833 B]  
Get:33 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [40.8 kB]
Get:34 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [66.3 kB]
Get:35 http://security.ubuntu.com/ubuntu focal-security/multiverse amd64 DEP-11 Metadata [2,464 B]
Ign:31 https://mkvtoolnix.download/ubuntu bionic Release.gpg
Get:36 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 Packages [1,711 kB]
Get:37 http://archive.ubuntu.com/ubuntu focal-updates/main amd64 DEP-11 Metadata [278 kB]
Get:38 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 Packages [916 kB]
Get:39 http://archive.ubuntu.com/ubuntu focal-updates/universe amd64 DEP-11 Metadata [390 kB]
Get:40 http://archive.ubuntu.com/ubuntu focal-updates/multiverse amd64 DEP-11 Metadata [944 B]
Get:41 http://archive.ubuntu.com/ubuntu focal-backports/main amd64 DEP-11 Metadata [8,004 B]
Get:42 http://archive.ubuntu.com/ubuntu focal-backports/universe amd64 DEP-11 Metadata [30.8 kB]
Ign:43 https://github.com/retorquere/zotero-deb/releases/download/apt-get ./ InRelease
Err:44 https://github.com/retorquere/zotero-deb/releases/download/apt-get ./ Release
  404  Not Found [IP: 140.82.114.4 443]
Reading package lists... Done                                                  
W: GPG error: https://mkvtoolnix.download/ubuntu bionic Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 74AF00ADF2E32C85
E: The repository 'https://mkvtoolnix.download/ubuntu bionic Release' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
E: The repository 'https://github.com/retorquere/zotero-deb/releases/download/apt-get ./ Release' no longer has a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 zerotier-one : Depends: libssl1.0.0 (>= 1.0.2~beta3) but it is not installable
E: Unable to correct problems, you have held broken packages.

*** Package installation failed! Unfortunately there may not be a package
*** for your architecture or distribution. For the source go to:
*** https://github.com/zerotier/ZeroTierOne

I fixed by following the fix in Incorrect OS detection for Linux Mint via installer script · Issue #1586 · zerotier/ZeroTierOne · GitHub

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.