Interesting problem

Hi guys,

I need a little help.

I use zerotier on several devices but one debian server does not work.

It’s a 7.11 (wheezy) and I cannot upgrade it.

I installed the zerotier 1.10.1, connected to a network: “200 info fbb94f98d9 1.10.1 ONLINE”, got a new interface with the right IP address, but cannot reach (ping) the other zerotier devices.

If I do a restart, I get the following:

/etc/init.d/zerotier-one restart
[ ok ] Restarting ZeroTier One: zerotier-one[…] Stopping ZeroTier One: zerotier-one.
[…] Starting ZeroTier One: zerotier-one/usr/sbin/zerotier-one: WARNING: failed to drop privileges (kernel may not support required prctl features), running as root
. ok
root@bix:~# WARNING: ioctl() failed setting up Linux tap device (set MAC)

root@bix:~# connect: Operation timed out

Can you help me to solve this problem? It will be very important to me.

Thank you!


I am no expert, but my 2 cents:

since the system is so old, consider using older zerotier? maybe try to use docker image, there is several versions available

make sure the tap module is loaded.

lsmod | grep tap

I have tried about all the zerotier versions but none of them worked.
I would like to leave the docker for the last step.

Not loaded. How can I fix it?

modprobe tun is one way.

It may take some work to get it available and loading, depending on your environment.

modprobe tun: nothing
May I ask more help please?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.