Linux Mint 20.3 missing

Installed zerotier-one and tried to run the cli “zerotier-cli” but get this

message: zerotier-cli: error while loading shared libraries: cannot open shared object file: No such file or directory

Is there a new package on the way? How can i fix this?

Thanks you for any help on this…

I installed an older version (1.8.7) then chosed to ignore the current update in update manager.

Thanks gorto1127, I was hoping the Linux Mint guys would fix this in an update… But i guess ill have to what…

Thanks again for help…

Linux Mint Update Manager updated my Zerotier to 1.8.10 today and it failed again. I think this is the problem of Zerotier, they need to fix it. I rolled back to 1.8.7 again and that works.

1 Like

You’d want to try to modify your source.list to the following:

deb bullseye main

The file is located under: /etc/apt/sources.list.d/zerotier.list

so that you’ll benefit from newer Debian package version, which will solve the problem.

Good afternoon,
I solved this error by doing the next steps:

  • Change the source.list of zerotier.list to
    deb Index of /debian/bullseye/ bullseye main
  • restart the laptop
  • remove zerotier-one version 1.8.7 from the laptop
  • restart the laptop
  • Install zerotier-one version 1.8.10 from the Software Manager
  • restart the laptop

It works fine.
Hope this helps


How did you go about rolling back zerotier? im having this same issue and cant find any info on how to do so

sudo apt remove zerotier-one

then install an older version

Thanks for pointing to 1.8.7! I tried Raul’s fix, but cannot get 1.8.10 to work on a Linux Mint box with 20.1 (Ulyssa). Here is what I used to downgrade from 1.8.10 to 1.8.7.

sudo apt remove zerotier-one
curl --output ~/tmp/Zerotier_1.8.7.deb
cd ~/tmp/
sudo dpkg -i Zerotier_1.8.7.deb

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.