Unable to connect with older android devices

Hello.

I own a few old android devices such as the Ouya and MadCatz M.O.J.O.
Those devices only support Zerotier v1.4.6 because they run Android 4.1 and Android 4.2.
However, I cannot connect with this older version.
If I install the latest Zerotier on my current smartphone, I am able to connect to my network. But if I install the old v1.4.6 apk on the same device, I am no more able to connect.

So can you enable support for the v1.4.6 app ?
Another person had the same issue.

Thank you