1.10.1 Still not starting on MacOS

I just reproduced this issue on Monterey: ZeroTier 1.10.1 GUI doesn't start on macOS

The various tips about downgrading don’t appear to work. Zerotier is running, and the command line works, but the system tray gui does not, making management difficult for end users.

This does not happen consistently - my own mac is currently running 1.10.1 and it seems to work fine (for now).

We’ve seen the reports, but unfortunately none of us here at ZT have ever been able to reproduce this and we all run on macOS.

Is there anything running on your system that would prevent the UI from talking to the service? System firewall or 3rd party firewall?

When I install ZeroTier on a new computer for the first time and then open the menu bar to select “Start UI at login” I get a popup from macOS regarding permission for ZeroTier to access “System Events.”

Can you check something on your side?

  • Go to “System Preferences” and then “Security & Privacy”
  • Click on the 4th tab “Privacy”
  • Scroll down on the left side and highlight “Automation”
  • On the right side, is “System Events” checked underneath ZeroTier.app? (You WANT it to be checked)

That would be my assumption for your situation. I have installed ZeroTier on multiple Macs running 12.6 Monterey this last week and have not had an issue of the GUI (menu bar) showing up after restarts.

There may be a log in the Console.app that could point to the issue but I would start here.

Hope it helps!

It’s a plausible explanation, but that checkbox is already enabled…

Dang okay… I re-read the other thread you linked and I believe I missed the point that NO GUI launches at all after installing… Not just after a restart… Which is something I have not experienced myself.

I was trying to see if there is some sort of “permission” issue that may be causing it but it’s as you stated… everything seems to have installed correctly and it’s “working” but the GUI never showed up…

Just to ask a few other things… Any special setup for the Mac you have?

  • Is this a personal machine or a work machine with maybe some “work guidelines” (profiles) setup?
  • Is your user account an administrator? Or are you installing ZeroTier within a non-admin account?

I am not sure what is causing this for you… It may be helpful to open the Console.app in /Applications/Utilites/ and then click “Start Streaming” messages. Then go to your Applications folder and open “ZeroTier.app.” Maybe there is a message the console may show saying “Could not attach menu bar because of …”

Same problem here, M1 and M2 Macbook Airs

I also have this issue on an M2 Air.

1 Like

This is a work machine and I am the administrator. However, I am using Mosyle to manage these machines and it is possible that there is a difference between installing zerotier by hand and installing it via Mosyle. I’ll have to run some experiments to see if the manner of (initial) installation makes a difference.

I have same issue on macOS running Monterey. Cannot launch the zerotier application.
pls advise how to troubleshoot.


I fixed this issue through the following procedure:

  1. Quit the Zerotier UI
  2. Open a terminal
  3. Incant rm -rf ~/Library/Application\ Support/ZeroTier
  4. Start Zerotier UI

This forced Zerotier to request an administrator password, after which the UI worked again.

I suspect that during (re?)installation the authentication token that manages the interface between the UI and service components gets regenerated, but not updated in all places.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.