1.6.0 Status PORT ERROR macOS Sierra 10.12.6. SOLVED with ZeroTier 1.6.1!

Hi there, I tried to connect to a ZeroTier network created with Windows but I get “PORT ERROR” on Status when I open Network Details window.

macOS Sierra 10.12.6
ZeroTier 1.6.0
System firewall disabled, antivirus disabled

Same issue as here 1.6.0 no ips assigned on macos 10.13

Working on a fix.

Or you just have to approve the kext in your system preferences. 10.12 and prior require a kext for the network adapter.

from 10.13 High Sierra not 10.12 Sierra

Is the kext approved System Preferences? If you haven’t done that already, you may have to reboot to get it to pop up in there again to be approved.

Well I just found out from another team member that the kext isn’t included in the installer because Apple won’t notarize the installer if there’s a kext in it. :man_facepalming:

Working on a solution.

Problem solved with new version ZeroTier 1.6.1!

I run ZT 1.4.6 on a few macs mostly 10.14 but one that is so old the max it can run is 10.11. It’s just a home network with some remote macbooks.
Can anyone advise if it’s safe to upgrade to 1.6? Second question, if something doesn’t work, how easy is it to roll back zerotier on the affected machine, and would I need to roll back every machine or can there be a mix?

The different versions are compatible with each other.

Old installers are available here

If switching between versions on a Mac, You may run into some annoying issues around allowing the kernel extension https://zerotier.atlassian.net/wiki/spaces/SD/pages/7241787/PORT+ERROR+on+Mac

If it’s a home network, you may not need any of the 1.6 features and can just stay on 1.4. Up to you.

1 Like

Thank you for that… I think I’ll just stay on 1.4 then.