401 Status {} after upgrading to 1.12.0

I’ve got a server running Ubuntu 22.04, that was running great on 1.10.6. However, we had to re-install the server for testing yesterday and the install script installed 1.12.0.

The installation is successful and comes online upon auth on the expected ZT network.

$ sudo zerotier-cli status
200 info 95e47aba84 1.12.0 ONLINE

However, a few minutes later, the ZT connection becomes unreliable, dropping offline and coming online at random times. When looking at the status it shows 401 Status []. It shows 401 Status for every command I run. I know this is an access denied error, but I can’t find a way to solve it at all.

$ sudo zerotier-cli status
401 status {}

I’ve removed the client, purged all config, reinstalled, same result. I’ve check auth tokens as per previous posts. I’ve even went as far as reinstalling the OS again, ending with the same result.

Once it gets in the 401 Status error state, nothing I do changes the outcome. Reinstalling, purging, etc. It all instantly results in 401 Status.

Is this a known issue with a fix, or do I need to revert back to 1.10.6? If I can figure out how to do that manually.

I’ve dug deeper into this. I’ve found that out iptables post routing rule was causing the issue.

iptables -t nat -A POSTROUTING -j MASQUERADE

Once you enter that rule, instant 401 status. Deleting the rule, ZT comes back online without issue.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.