Android app will not toggle network ON - Shows offline

First time ZT user. I have created a network and have successfully connected an iPhone running the app to the network. However, on my Android, It will not let me toggle the network on. It just keeps flipping the switch back to off immediately and says I am off line at the bottom of the screen. Any ideas on what I’m missing?

Update: I’m running CalyxOS. Seems to run fine on a standard Android with OS 12. Cannot get to work on any CalyxOS device

The ZeroTier Android app is known to run on CalyxOS.

The behavior of switching back to off immediately sounds like another VPN may be interfering.

Here is a scenario:

Another VPN (e.g., Riseup VPN) is configured to be Always-on

Inside ZeroTier, try to connect to a network.

The first thing that happens is VPN authorization is requested.

This is immediately canceled by Android because another VPN is already set up.

This is the same cancelation behavior as tapping “Cancel” when the VPN authorization dialog pops up when using the app for the first time.

The app has no way to distinguish between the cases of “Another VPN is configured to be Always-on” and “User canceled the authorization”.

The ZeroTier app acts as if the user canceled the authorization (i.e., resets the toggle, etc.)

Please verify that no other VPNS are configured and interfering with ZeroTier.

That did it! I run MullVad VPN as an always on VPN. So I cannot run MullVad with Zerotier? If not, is there a way yo use Zerotier as a replacement VPN instead of MullVad?

Thanks for the help!


You can disable Mullvad VPN as Always-on VPN. Then you will be able to use ZeroTier.

From Android docs (VpnService  |  Android Developers)

There can be only one VPN connection running at the same time.

You can still have Mullvad and ZeroTier on the same device (and starting one will stop the other), but if one is configured as Always-on, then that prevents the other one from starting.

Got it. I was able to put it on the work profile (and my MullVad on my main profile) and use the zerotier VPN on the work profile.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.