(Android) Zerotier keep stop working after 1.10.3 update

Hi, since recent update, my zerotier occasionally stop working, when :

  • Try to tap/open my network → my device says it stop working and forced closed.
  • Open other app → zerotier will disconnected eventually. I think it can’t run in background.

Previous zerotier (1.8.9) work fine in my device.

My device is Samsung M12

Is this just happen to me or other also have this issue?

1 Like

Is there a downloadable previous version? I want to stay on previous version.

Is there any solution for this bug ???

Also many network are not able to connect through zerotier after the last update

1 Like

Zerotier has transformed how I interact with my home LAN when travelling. Brilliant idea. However this latest android update 1.10.3-1 has completely broken my links from all my android phones (Android 11 & 12) to my LAN. I’m distraught!

With great difficulty I’ve now downloads 1.8.6.apk, uninstalled 1.10.3 installed 1.8.6, but had to completely setup from scratch and all is working again. 1.10.3 is toxic!

Same problem here. Yesterday it worked perfect and now as you say when I tap on the network the app crashes.

I’m having the same problem! @guru.gubbins , where did you dl the 1.8.6 apk? Would hate to revert back but if that’s the fix.

I’m unable to give you a direct link from here but the Zerotier site downloads page has an older version link covering various platforms. The apk file I downloaded was supposed to be 1.8.9 but turned out to be 1.8.6 and it only installs after removing the newer app so all settings lost!!

Hello, we are working on a fix for the problems that people are having. There will be a new release later today with some fixes and we are still trying to reproduce all of the problems that people are seeing.

Please describe your device (model and Android version), and your network setup (the various settings of your networks).

If we still have trouble reproducing the problem, we may ask if people would be willing to help with debugging.

1 Like

I did the downgrade and it worked again. The link can be found here:

I’m not aware of any problems on my windows and linux systems on the LAN after recent Zerotier updates. It’s a Motorola G7 Power (Android 11) and a Motorola G100 (Android 12) which have been shafted this morning with 1.10.3

Yep that’s it, but installs as 1.8.6 - but at least it works

I found the problems in all the android devices I tried (Poco X5 pro, X3 pro and Samssung s21).
Either with Wifi or Cellular Data. All worked yesterday and stopped functioning after upgrade

I also have the same problem with the new update, it does not work.

I already tried and it doesn’t work with other devices Android 11, S10+ with Android 12 works well

With a Samsung s22 running Android 13, and the simplest non routed no dns class c net in zerotier it stopped working.
zerotier.com shows that the device is connected but soon reverts it. The same goes for the client. It shows connected but goes offline after a while, less than a minute.
The vpn status bar icon never appears.

Same here, samsung s21, stock. App connects but drops the connection after a short while, like 1-5 min. The notification in the drawer says connected but when i check status on zerotier site or open up the app again it says dissconneted. Have been trying wi

I had some troubles with all my devices in the morning, right now I downloaded it from my S10+ and it works well, later on, I’ll try on the other devices.

Sorry for the late reply on this thread. Yes we’re aware of the issues. It was an issue nobody in house could reproduce on their phones until someone tracked down, bought & picked up one of the phone models having issues. The issue is deep within the JNI code between Java & C++ and only presents itself on some phone models and doesn’t really make any sense. (For the developers in the crowd, it appears that some Android runtimes are having issues with the number of var args in a call from C++ to Java).

Unfortunately, the Google Play store gives us no way to “unrelease” something and go back to the previous version, so we’re working to fix the issue ASAP.

The old APK is available from our downloads page if you’re OK with side-loading an app, however you will lose your configuration doing it this way. The old APK is available here: https://download.zerotier.com/RELEASES/1.8.9/dist/ZeroTierOne.apk


Update: A new release is going out via Google Play. The update should be available shortly.


Installed and the update works good. Thank you.

1 Like