Another Occurance of Waiting for ZeroTier System Service

My computer ran into an issue recently and all of the applications were removed. I tried installing it but when I tried to run it, I could not open the desktop UI panel. It said “waiting for zerotier system service”.
I have looked elsewhere on the forum and could not find an answer that worked for me. One other post recommended changing the security permissions on ProgramData/ZeroTier to enable inheritance. This did not work for me, as the Enable Inheritance button was greyed out. The .secret files are also identical. I tried to reinstall it, but I ran into the same issues after running the installer again.
I could not figure out how to uninstall everything, so there might have been remnants of the previous installations that are screwing things up… not sure though.
I have used zerotier before and it worked smoothly, but I am in no way an expert.
Any recommendations?
ty

Ok, I certainly should have tried this earlier, but

  • I tried to uninstall it to get rid of the vestigial files and whatnot, so I looked up how
  • I found out there is an option on the installer
  • I also found out there is a repair option
  • I used the repair option
  • Suddenly it works
    Sorry for the post, it was a bit unnecessary

tl;dr I fixed it by right clicking the installer and selecting “repair”