Arch Linux computer loses ZeroTier connectivity


I have a ZeroTier network with two nodes, one is a RPI running Ubuntu and the other is a computer running Arch Linux. Both use ZT client 1.6.5

The Ubuntu RPI works fine, but from time to time I find that the Arch Linux computer seems to have been kicked out of the network. The computer have a working internet connectivity, and ZT client actually thinks it’s a part of the network when running zerotier-cli listnetworks, but the web interface of ZT shows that the node is offline, and in one of the times that this has happened, the web interface actually showed that the node is online despite the fact that I stopped the ZT client.

Deleting the node from the network and readding it doesn’t help. The only solution I found so far was to SSH to the node, delete the ZT key, restart the client and add the node back to the network again with its new key, but since this issue keeps happening I can’t keep performing this workaround.

There doesn’t seem to be any valuable logs from the ZT client, so I don’t have a clue about what’s going on.

Coma Bug Update check here for a slightly easier way to reset.

What is different about the arch computer’s internet connection than the ubuntu one? Check arch’s iptables rules and any NAT and firewall settings in its internet router.

Changing the secondary port fixed it, thanks!
The computers are connected with different ISPs, and both routers are provided by the ISP itself so I have little control over them. I suppose either the router goes crazy or the ISP decides to block the ports.


I just tried this out:

echo "{\"settings\":{\"secondaryPort\":$((1024 + $RANDOM % 64510))}}" | sudo tee "/var/lib/zerotier-one/local.conf"

You could put something similar in a timer maybe, or just run it when you need to.

This will all by fixed by zerotier itself someday

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.