At which minimum version does the ZT on Synology DSM 6 start to support end to end encryption?

Hi all,
I have a Synology DSM 6.2.3 running with ZT 1.4.0. It is a production NAS, and I have no plan to upgrade it to DSM 7.1. I will stick to the ZT package for DSM 6 provided by the official website

And, I have a remote VPS running with ZT 1.10.0, mounting one shared folder from that NAS through NFS protocol. As there’s a considerable version gap between these two nodes, I wonder if the end to end encryption still works. If it doesn’t work, what is the minimum version of ZT should I install on DSM 6 ?

thanks
Sam

No worries. All versions of ZT are backwards compatible. Encryption works between your 1.4.0 and 1.10.1 boxes.

Since undocumented bugs exist in some of synology’s networking facilities that make it difficult for ZT to do its job the upgrade path on Synology is not quite straightforward or reliable. I wouldn’t attempt an upgrade unless you have physical or LAN access in case you lose your connection. That being said, 1.8.7 is the latest package we have for Synology and it should work for you on DSM 6.2.4.

Hope this helps.

Also, a word of caution. I’ve seen many reports that having QuickConnect enabled will prevent ZT from working in some cases (years ago). So be aware of that risk if you decide to use that as your backup connection.