Broadcasting stops every 30 seconds

Hi all,

I’m connecting two RaspBerry 3 with ZeroTier and sending L2 Broadcasting messages every X seconds from NodeA to NodeB. All works fine, and I can see my GeoNetworking traffic (ethertype=0x8947) on the otherside, but NodeB stops receiveing the broadcast messages from NodeA every 30 seconds. Looking a bit further, seems that the messages are correctly received during 30 seconds and then stops for 30 seconds, in a cyclic way. Both nodes have been connected directly to debug this behaviour, but it only happens when using Zero Tier network.

I’m using a Free Plan, but I didn’t see anything related to this restriction. Any ideas?

Thanks a lot!


Update: seems that the restriction is not by time, but by traffic sent. If I increase the ratio of sending Broadcasting messages, the UP time is reduced. So is there any quota?

Welcome. Thanks for reporting! There’s a github issue here for this:

Downgrade to 1.4.2 for now.
I think you can just do apt install zerotier-one=1.4.2-2 if it’s a debian based distro

Hi Travis,

thanks a lot, it worked like a charm! :smile:
Now we can broadcast our V2X messages without any interruption.

Marked as solved.



1 Like

This topic was automatically closed after 14 days. New replies are no longer allowed.