[bug?] Network leave does not work since 1.6.0


“Network leave” command does not work - it hangs for long time and times out. It’s working with 1.4.6, does not work with 1.6.0 and 1.6.1. I does not matter which network I am trying to leave. I even tried to create new network - same thing.
Ubuntu 20.04.1. Zerotier installed via apt.
Any ideas what is happening and/or how to debug it?


1.6.1 doesn’t work with multiple networks on Linux, I’ve reported this but it’s a wrong use case apparently.

@auro Thanks for reporting this. We’ll take a look and update this thread.

@Michal What flavor of Linux are you seeing this on? And where did you report it? Because multiple networks on Linux is definitely a supported use case.

Ubuntu 20.10 on amd64. I reported here. In hindsight, not the most visible way so I’ve also opened a GitHub issue now.

Version 1.6.2 fixed it for me.

1.6.2 fixed it for me too. Great!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.