Cannot get Multipath to work

I am trying to get MultiPath to work, I guess I am missing something.
Output from zerotier-cli -j status:

{
“address”: “xxxxx”,
“clock”: 1614704002980,
“config”: {
“physical”: null,
“settings”: {
“allowTcpFallbackRelay”: false,
“bind”: null,
“controllerDbPath”: null,
“defaultBondingPolicy”: “broadcast”,
“portMappingEnabled”: true,
“primaryPort”: 9993,
“softwareUpdate”: “apply”,
“softwareUpdateChannel”: “release”
}
},
“online”: true,
“planetWorldId”: 149604618,
“planetWorldTimestamp”: 1591823606334,
“publicIdentity”: “xxxx:0:xxxx”,
“tcpFallbackActive”: false,
“version”: “1.6.4”,
“versionBuild”: 0,
“versionMajor”: 1,
“versionMinor”: 6,
“versionRev”: 4
}
zerotier-cli listbonds just reports “None”
To be on the safe side I have enabled multipath:broadcast on both sides.
As far as I understood I dont have to configure the peers manually, so that should work already?
But it doesn’t, so what am I missing?

Small Update from me:
I got the configuration that both sides report to me that the standard configuration is to use broadcast mode.
The remaining problem is that the dont bond whatsoever, and I dont know what I have to configure to get the bonding to work

facing same problem on ubuntu 18.04 on a virtual machine having two networks alive, using zerotier version 1.6.4, zerotier multipath bond with policy “broadcast” not bonding whatsoever.
zerotier-cli listbonds -j
shows no bond created

Can you please show which is or linux flavor worked for you? Besides this can you share you local.conf which worked for you?

Documentation shows only option"dedup" can be set to true on receiving end, I don’t know setting “dedup=true” is compulsory or optional, I have tried both but failed. Any help?

As I wrote above, bonding still doesn’t work for me.
I have no idea how to get it working, and no one seems to be willing to help.
I will update you if I make any progress, please do the same!

Hello,

Can I see how each of you have your local.conf configured?

Hi, sure!

On my windows it looks like this:

{
“settings”:
{
“defaultBondingPolicy”: “broadcast”,
“peerSpecificBonds” : { “5072902008” : “broadcast”},
“policies” : {
“links”: {
“Ethernet 2”: {
“mode”: “primary”
},
“WLAN”: {
“mode”: “primary”
}
}
}
}
}

I tried without peerSpecificBonds and without the links argument, but doesn’t work either way.
On the other end (ubuntu) the config looks the same, with the other Node-Id and without the links argument.

@zt-joseph did you have time to take a look?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.