Can't connect Mikrotik ARM device

Hello all,
When trying to add a mikrotik ARM router to my network, I had a weird problem:

when adding interface i Get ACCESS_DENIED status, that’s normal, since my is a private network, I have to authorize members, but on the zerotier site administrator interface I can’t find my newly added node.

[admin@192.168.2.1] > zerotier/interface/print
# NAME       MAC-ADDRESS        NETWORK           STATUS       
0 zt-VinxDB  6A:84:D4:xx:xx:xx  632ea290xxxxxxxx  ACCESS_DENIED

So I temporally changed my network in public mode, and immediately my device connected.

[admin@192.168.2.1] > zerotier/interface/print
#   NAME       MAC-ADDRESS        NETWORK           NETWORK-NAME  STATUS
0 R zt-VinxDB  6A:84:D4:xx:xx:xx  632ea29085xxxxxx  VinxDB        OK

I got an IP Address

[admin@192.168.2.1] > ip address print where interface=zt-VinxDB 
#   ADDRESS         NETWORK      INTERFACE
3 D 10.147.17.6/24  10.147.17.0  zt-VinxDB

routes

[admin@192.168.2.1] > ip route print
#     DST-ADDRESS      GATEWAY      DISTANCE
  DAc 10.147.17.0/24   zt-VinxDB           0
  DAv 192.168.1.0/24   10.147.17.1         1

I can even ping other nodes and also networks behind them

[mtkadmin@192.168.2.1] > ping 10.147.17.1
SEQ HOST           SIZE TTL   TIME
  0 10.147.17.1      56  64   61ms672us 
  1 10.147.17.1      56  64   68ms262us 
  2 10.147.17.1      56  64   60ms126us 

[mtkadmin@Hap-AC2] > ping 192.168.1.1 
SEQ HOST            SIZE TTL  TIME     
  0 192.168.1.1       56  64  64ms72us  
  1 192.168.1.1       56  64  56ms933us 
  2 192.168.1.1       56  64  56ms257us

same thing from the other node, I can ping both zt and lan ip address

[admin@192.168.1.1] > ping 10.147.17.6
SEQ HOST            SIZE TTL    TIME  
  0 10.147.17.6       56  64    73ms362us 
  1 10.147.17.6       56  64    100ms719us
  2 10.147.17.6       56  64    67ms362us 

[admin@192.168.1.1] > ping 192.168.2.1
SEQ HOST            SIZE TTL    TIME  
  0 192.168.2.1       56  64    72ms953us   
  1 192.168.2.1       56  64    63ms597us 
  2 192.168.2.1       56  64    143ms264us

But in the admin interface I still can’t see my node.

How can I resolve this?

I already tried to remove and rejoin node, but still behave the same.

the CHR you can see in the screenshot, is a virtual machine I joined for test, to be shure the problem is related to my mikrotik router and not a general issue.

I’m not sure if you solved this, but in case others find your thread. Under your nodes, there’s a way to manually add a node. I’ve had what is happening to you a couple of times, and doing this usually helps. Just put the node address that isn’t popping up in the “Manually Add Member” box and click “Add New Member”.

image

The problem is still going.
I know i could manually add a member, but I cannot find my client node-id.
with windows or linux client is easy, even with microtik container client. but with the client embedded in routeros I can’t find the information.

Here’s a couple ways to find the node-id:

GUI

Go to ZeroTier->Instance
Click on the configured instance
The first 10 digits of the identity is the node-id

CLI

Type /zerotier/print
There will be a very long identity string, again the first 10 digits of that is the node-id

Hopefully that helps.

[admin@192.168.2.1] > /zerotier/print
Flags: R - ONLINE
Columns: NAME, PORT
#   NAME  PORT
;;; ZeroTier Central controller - https://my.zerotier.com/

The CLI command gave me an empty string, but found it by the GUI.

and now I can see my device among members

Thanks for your support.

No problem, glad you got it working!