Connection stops working on Android only when game is open

Hi. It has been months since I first tried this and I still didn’t find a solution to the issue. ( '-.-)

I’m creating a Minecraft Bedrock Dedicated Server to play with my friends since Bedrock allows for cross-platform and half of them don’t have a PC available now. The process is simple, just like a Java server. I decided to use ZeroTier One to create a Virtual Lan network like Hamachi since it works on both Windows and Android and allows more than 5 users in a network. The server is hosted by a PC. All versions are 1.6.2. Minecraft is 1.16.201 (was 1.16.100 when I recorded the videos)

By testing I got it working fine between two Windows PCs (able to join the server) but it got some issues on Android.
By testing through ping I discovered that ZeroTier One is working fine connecting the phones to the PC, but everytime and only when Minecraft Pocket Edition is open and running in a phone, the ping drops to “Request timed out.”, and so one is unable to join the server.

I tested in different phones:

  • Xiaomi Redmi Note 7 - Issue happened
  • " Redmi Note 8 - Issue happened
  • " Redmi 8A - Issue happened
  • " Redmi Note 5 - Issue happened
  • " Mi A2 - Worked fine
  • Asus Zenfone Go - Worked fine

Here’s two logs of zerotier-cli peers on cmd while checking the connection on the Redmi Note 5:

  1. Switched out of Minecraft on the phone. Ping average is 90ms.
    <ztaddr> <ver> <role> <lat> <link> <lastTX> <lastRX> <path>
    [Phone ztaddr] 1.6.2 LEAF 224 DIRECT 454 278 [censored]/9994

  2. Switched back to Minecraft on the phone. Ping only logs “Request timed out.”.
    <ztaddr> <ver> <role> <lat> <link> <lastTX> <lastRX> <path>
    [Phone ztaddr] 1.6.2 LEAF 224 DIRECT 3338 15132 [censored]/9994

To make things more confuse to me I was testing the Redmi Note 8, which was showing the same issue, and then, without any configuration changes, the issue disappeared and never showed again in this phone. I supposed I did some sequence of actions that made this happen. I simply opened the Options menu in the game as soon as I switched back. I tried replicating this with the Redmi 8A but didn’t work the same way. It worked by opening the Options menu, switching out, re-establishing the connection and switching back (options menu is open). Wasn’t successful in any of the other phones.

Here’s a video recording montage:

Found the cause and a fix. The issue happens on Xiaomi phones only due to some having a built-in “Game Turbo”.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.