Connectivity Issues with 1.14.0

I’ve used ZeroTier for several years with no issues and currently have over 20 devices on my ZT network. Recently, I added a new Android device to the network. Since it’s a new device, it installed the latest version, 1.14.0. The device was successfully registered on the network, and I can see it as connected in my admin panel, but it’s unable to connect to other devices on the network. I tried everything…uninstalling/reinstalling, following all the troubleshooting tips, etc… Everything looks normal, but it can’t connect. Then, thinking it was an Android issue, I tried installing 1.14.0 on a Windows device. It had the exact same issue. I could see the device as connected in my admin panel, but the device wouldn’t connect to any other devices on the network.

I tried pinging the ZT IP address of another device and the ping failed. Even more strange, the failed ping attempts show the ping coming back from a different IP address on a totally different subnet. Once again, I did all the troubleshooting steps, completely disabled the Windows firewall, etc, etc, etc… Nothing worked. Then, I uninstalled 1.14.0 and installed 1.6.6. It now works perfectly! Therefore, I can only conclude that there’s some issue with 1.14.0. Since it happened on two different devices, I can’t imagine that I’m the only person experiencing this.

Yeah I was having the same issue after updating from 1.8.7/1.8.9 to 1.14.0.and also issues with mtu settings.
To get things working again I had to make sure that the devices on the network were all connected and online then change the IP range of the network.

But if a device was turned off (went offline) and came back online there would be intermittent packet loss to that device lasting from 5s to 20s untill the IP range of the network was changed.
Also I have found that if a device restarts the zerotier service they loose all connectivity to the zerotier network until the above is done again.

1 Like

Yeah, no way am I getting involved with changing the network IP range. It sounds like there are some major issues with 1.14.0, so I will just stay on an older version for now and hopefully they will fix the issues.

Are you using the rules engine? If so, try adding accept ethertype arp; to the top of your rule set.

1 Like

No I am using default rules of:

drop not ethertype ipv4 and not ethertype arp and not ethertype ipv6 ; accept;

Also all the devices on the zt network are Windows.

We had the same issue after updating to 1.14. Downgrade to 1.12.2 solved the issue. After this i added accept ethertype arp; to rules and upgraded to 1.14 again, that solved the issues with 1.14.

2 Likes

I added accept ethertype arp;
But I am still having the issues I had before so I think I will have to downgrade to 1.12