Devices look offline on network configuration page, but in fact they are online and reachable

The title is self-explanatory. I had this issue on different devices on different ZeroTier versions and ZeroTier networks. The devices had stable internet connection with wired Ethernet, I checked their connection and I was able remote login with ssh no problem. But on the the network configuration page, they show up as inactive now but was active few days ago. Or even not showing up at all (in this occurrence, I had the IPs written down earlier so, I was able to ping and ssh into them). Any idea why this is happening?

What do you mean by “look offline”? How are you determining that they “look offline”?

As I said in the original post. Their status is “inactive” in zerotier network configuration page. Or they don’t show up at all. When a device joins the network, it should pop up in network configuration page and there under status it shows online, right? These two devices on different networks and different zerotier versions did not. But they are accessible, because ping and ssh works.

The controller only knows the last time the node checked in with it. There’s no persistent connection between the controller and network members. As such, it reports the last time it was seen such as “Less than a minute ago”, “About 2 minutes ago”, etc. The controller can’t tell whether a node is online or offline directly.

Yes, I read the announcement from April 2023 about how controller gets status updates from devices with UDP and not an active TCP connection so you shouldn’t rely on them. But these devices status never gets updated even after hours of being in the network. Mostly they don’t even show up. I’ve been using ZeroTier for at least 4 years now, and I’ve never seen that behavior before. Just wanted see if anyone else has seen this before, or it is something seen recently.

Are you using the optional New member list?
image
If so, it does not automatically update in the background. There’s a refresh button that you can press for it to update.

Additionally, if you’re using the “Inactive” filter, the list will only show members that haven’t checked in with the controller recently. Uncheck “inactive” (old member list interface), or switch the All/Active/Inactive filter to All (new member list interface)

I haven’t opted in the new members list yet, so I don’t think that’s what causes the issue unless you updated how status gets updated, and even though I am not opted in the new members list somehow my members list not updating as it should. I don’t know. And I am also aware of switching the filters so, I don’t think that anything to do with I’ve seen.