Different ping between PCs and Relay/Direct link problem


I have a PC (Win10 Pro) that runs MC server. My friends can connect, but three of them have a RELAY link. I spent a lot of time reading documentation, reddit, and even tried chatGPT, and I managed to fix one relay to direct by allowing UPnP on my friend’s router.

Friend No.2 has allowed UPnP on their router (TP-Link Archer X53), and ZeroTier is allowed in the firewall. I can see his physical address in the ZT Web. Also, I can see UDP connections in his TP-Link web UI. Still, the connection is relayed.

Friend No.3 also tried allowing UPnP, but I can’t see their physical address. Today, a strange thing happened. They had a RELAY connection, then suddenly it changed to DIRECT. They didn’t do anything. I can ping them from my notebook (not on the same local network as the server) and get 17ms. They can ping me back, also around 17ms. What’s strange is that when I ping the server, I get 19ms, but my friend gets 50ms. Why? Also, in surfaceAddresses, he has 6 addresses, while I have only 3.

About network setup:
Friends 2, 3 and me have very similar setup. GPON (optic fiber) → internet provider’s converter → router → pc
My internet speed is 300/100. In my network, where the server is running, UPnP is enabled and no port forwarding set. My router is a TP-Link Archer 1200.

(Provider’s converter (router/wifi) doesn’t have much options. We can only tinker with wifi on/off and name. No UPnP or other settings.)

I’m running out of ideas. Any help would be very much appreciated.

I allowed DMZ to server’s ip - still no success.

I think I found the problem. The server and the two PCs that have a relay connection have the same ISP. PCs with direct connection have different ISP.

I wrote an email to my ISP asking if they are restricting this kind of connection in any way.

Problem solved

My ISP is providing “router” which serves as GPON converter. So my network looked like this:

GPON → converter → TP-link → server

Now server is directly connected to converter:

GPON → converter → server

Problem was i think double NAT. Still mystery is why PCs from different ISP could connect directly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.