Endless Loop of Admin Password Requests

Since version 1.8.4 I have a number of Windows 10 desktops where users are unable to launch Zero Tier because it asks them for Administrative Password. When I enter mine it the admin window keeps popping up in an endless loop. The only way to exit it is to close Zero Tier in task manager.
I can run the application if I select “run as administrator” but I can’t be doing that every time some reboots their system. I do have Zero Tier set up to start automatically but it is not doing it.
Is there a way to fix this?

1 Like

Hi,
We are also seeing this. It’s not all of them and it seems to be those who didn’t open the client before we upgraded them to 1.8.4. Those who had the client open when we did the upgrade seem to be okay, but we don’t have a massive userbase to confirm this with (as most people just leave it connected all the time).

The workaround we’re using is to manually copy the authtoken.secret file from “C:\ProgramData\ZeroTier\One\authtoken.secret”
to
“C:\Users\<username>\AppData\Local\ZeroTier\One\authtoken.secret”

After that, it seems to open just fine.

1 Like

The workaround worked for me as well. Thank you!

hello.

I have the same problem of endless administrator user solution and the zero tier application does not finish executing

Workaround that Bryn posted worked for me. I recommend trying that.