Error processing OIDC login token exchange

I’m suddenly not able to login and manage my 30 devices. It has been working fine until now.
What perhaps has happened is that one of the devices (Home Assistant’s spread out on different locations in Sweden) needed to be upgraded from Raspberry pi to a stronger Odroid and I moved all data over, including the ZeroTier addon. I swapped the devices yesterday and I was surpriced that I still could reach this new machine on the same address (which I still can). But back home I realized that I couldn’t download anything to it. And now… I can’t login to ZeroTier, which is really bad for me!
What has happened? What can I do?

2 Likes

I have he same issue as well.

Hi, I have the exact same problem.
Initially I solved clearing all cookies from my browser but now it doesn’t work anymore

I want to add that I’ve also tried clearing all cookies etc, but no change.

Same here when trying to login to my.zerotier.com using Microsoft/OAuth.

Get redirected to this URL after Microsoft login page:

https://my.zerotier.com/api/_auth/oidc/callback?state=state&session_state=<...>

With this error message:

{"type":"internal","message":"Error processing OIDC login token exchange"}

We have the same issue - Using Microsoft as Auth Metho.

I am getting the same message using standard email login with 2fa. have not tried without 2fa. Oddly, when going to the main zerotier site and clicking sign in from there, after trying to login at my.zerotier, it let me in once. Once i logged out i cannot get past the error.

Sorry about the issue. Ran into an issue with our auth backend. Should be fixed now.

1 Like

Phu, yes it works again. Thank you and thank God :slight_smile: