Fresh Network Unable to Reach Peer

Hi Everyone,

I’ve been using ZeroTier for probably about a year or so now and I’ve never had any real problems that weren’t the fault of me simply not reading documentation or tutorials correctly.
Recently I seem to have lost the ability to reach (Some) other nodes in my Network/s.
I seem to be able to reach most other Windows machines fine but it seems I can’t reach other new machines, i.e. a (Windows 11) laptop I recently bought.

I have one Network with 14 nodes in it and it’s used to connect to a Perforce server running in a Debian ProxMox VM. My desktop was able to reach and connect to the server without issues until about a month ago. Which unfortunately aligns with me upgrading to Windows 11 as well as receiving a static IP from my ISP and fiddling with some router settings that I would not be able to recall for you.

Other people in the network seem to be able to reach the Perforce server as normal.

To try and isolate the problem I created a new network and a fresh Debian LXC Container. I installed ZeroTier on the container, and only added my Windows 11 Desktop and the container to the new network.
For my container I tried both of these solutions separately:

to no avail.

Also my zerotier-one service keeps logging zerotier-one[416]: connect: Connection refused

I’ve restarted, deleted my peers directory on both machines, set my Windows 11 network to private, basically done all of the basic “Have you turned it off and on again” solutions I can find and still I can’t reach the other machine.

I have tried connecting to networks other than my home network and I still can’t reach the Debian machine.

I can reach it via it’s LAN IP with no issues.

I’m not very network-savvy so I don’t even know where to begin to try and diagnose larger issues.

My network is using Pi-Hole as a DNS if that’s important.

Sorry if this is messy and a bunch of problems all duct-taped together. Any help would be appreciated.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.