Full tunnel slow

So after following this guide to setup zerotier on my OpenWrt on my router, I am able to access my local network through zerotier. (https://github.com/mwarning/zerotier-openwrt/wiki)

After that success, I wanted to set up a full tunnel, so I followed this guide: https://zerotier.atlassian.net/wiki/spaces/SD/pages/7110693/Overriding+Default+Route+Full+Tunnel+Mode

The full tunnel does work, but the connection is slow as I only get 5 Mbps up and down, my internet can do 600/100.
zerotier-cli peers says the link is relay:

Tried following the zero tier troubleshooting guide for Router Configuration Tips to fix it but to no avail.

My best guess is due to cgnat on both side, as my OpenWrt router is double natted on the local network + cgnat before reaching a publicly exposed IP (Tmobile ISP). While the testing device, my s20 on tmobile, also has cgnat before reaching publicly exposed IP.

I was wondering if there’s still another way to get a direct connection between my phone and my router or if my current setup/testing makes it impossible for a direct connection.


you’re right, if you’re behind a CGNAT and another NAT(?)… it’s extremely unlikely you’ll get direct connections to other things behind NAT. I don’t think there’s anything you can do productively, other than re-arrange things physically. Sorry! just don’t want you to waste a bunch of time.

Do you think if the client debice was not behind cgnat, would I be able to get a direct connection or no.

In terms of the local double nat, in a nutshell, I cant disable the NAT on the gateway (cuz Tmobile home internet moment) so just rolling with a double NAT atm.

Also thank you for the reply, just wanted to make sure the info I got off google was correct xd

It’s much more likely!


There would only be CGNAT for IPv4 so its even more important to set up IPv6. Step 4 of the full tunnel guide explains how to do this.

On the FAQ for the T-Mobile’s 5G Home Internet Gateway, it recommends to have your router in “bridge mode” so to improve IPv4 connections it would be best to do that with OpenWrt. I did double-check the Users Guide & the gateway’s WebUI doesn’t have an option to do anything else but let it manage non-ZT IPs for you. Not sure how exactly to configure this with OpenWrt but disabling DHCP & DHCPv6 may be enough to avoid a double-NAT.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.