[Help] Seems ZeroTier on my MacOS can't connect to ZT root server

Hi there, how is everything going at your side?

Previously the zerotier client on my Macbook Pro works pretty well, until several days ago it’s never able to connect to ZT root server any more.

Issue - stuck in status REQUESTING_CONFIGURATION
Version - 1.10.6
MacOS: Ventura 13.4 (Intel’s CPU)

I’ve read through a lot of posts across different forums including here, and tried different means, but didn’t work unfortunately.
Below are my steps of tries:

  1. Try uninstall and install several times, didn’t work

  2. Try the clean uninstall command line suggested in knowledge base, didn’t work

  3. MacOS firewall - I can make sure the ZeroTier application is added to let go list of MacOS, didn’t work

  4. Permission - tried adding ZeroTier application to the one having full disk access, didn’t work

  5. Use WireShark to observe something - it seems there’s no traffic outgoing or incoming when I kept trying connecting to / disconnecting from the network ID I entered. It seems that the traffic is purely blocked in the local machine

  6. Manually deleting some of the identity/authtoken files suggested from this forum (command line) and retry from the application on top task tray, still didn’t work

  7. Observe if it’s caused by my network - tried different networks at home/office/iphone-AP, all didn’t work. Primarily I thought it may be blocked by the ISP or something. It’s apparently not, because all my other devices on the same network ID works well, including Windows, mini router (OpenWRT), many ASUS routers, iOS, etc. So this is in particular an MacOS issue, and it worked well several weeks ago.

  8. Downgrade - tried downgrading to some of lower versions, and same again.

  9. I also suspected the file permission possibility even though I tried step 3 and 4 which seem to be related to the OS permission, so I added my login MacOS account to the permission of each and every files under the ZT folder (/Library/Application\ Support/ZeroTier/One). For once it worked, it’s connected to ZT root server successfully and stayed online - but without touching anything, it automatically disconnected again after half an hour, and I didn’t try the manual permission granting again because I think this is not the correct way of resolving this (MacOS needs to do it for each file, and granting it to the folder seems not working).

Till so far, I tried all the possibilities that I can think of, now I’m totally defeated…
Any idea what kind of root cause I’m having on this particular MacOS? Will really appreciate if you can shed light on figuring it out for me.

Thanks and best regards.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.