How can I remove my nodo from my iMac and install a new app (zerotier)

Hi everyone. I had to restore my iMac from my MackBook and then now my iMac has the same Zerotier’s nodo that my MackBook has. I mean, I have two devices with the same nodo.

The problem is that I cannot see the rest of my devices with my iMac when it is on the same network. I removed the zerotier and reinstalled it but my iMac always has the same node as my MackBook.

How can I remove zerotier and reinstall a new clean copy of zerotier on my iMac to join the same network where my devices are?

Any ideas?

Many thanks!

Hi there,

See here in the knowledge base.

Many Thanks! I’ll see it tomorrow, bedtime here.

I did it and it worked right. Thanks

Hi there!, I’ve had the same problem and I have done the same but now I can’t reset my ZeroTier address from my iMac. I have fallowed the same steps even I removed it an reinstall it Zerotier again but it didn’t work and I have two devices with the same Zerotier Address. I don’t know why!


Those are the steps. You have to stop ZeroTier, remove the identity files, and restart ZeroTier. A new Identity is automatically generated if there isn’t one present when ZeroTier starts.

Hi, I’ve tried several times those steps and the same. The ZeroTier address is always the same, alway de same. Even I did it with another user and always has the same nodeID. I don’t know why this time I can’t do it. Any idea? I really like ZeroTier, it is really, really useful. Thank for your time.

Are there any error messages when you run the commands listed in the knowledgebase article? There shouldn’t be any other output other than the next shell prompt when those commands are executed via the terminal.

Not at all, I run the commands and when I restar it with sudo launchctl load /Library/LaunchDaemons/com and then I run ZeroTier app and it runs with the same ID address and join to the same network.

That’s not possible if you’re removing the identity.public and identity.secret. It will still try to join the same network(s) unless you leave them first, but it’s not possible for it to retain the same identity once identity.public and identity.secret are removed from disk.

Hi, you can believe me. I followed all those steps over and over again. My iMac has two hard drives.

I installed a clean MacOS High Sierra on one of them and then a new ZeroTier application and yes, that ZeroTier runs a new node ID but when my iMac is restored from TimeMachine it runs the same as on my MacBook.

Why? I have no idea. My iMac is running MacOS High Sierra 10.13.6.

Thanks for you time

Yes, if you do a restore from Time Machine from another machine, it will also restore the identity. But once you delete the identity from disk and restart ZeroTier, the same thing I said in my previous reply stands. It is not mathematically possible to re-generate the exact same identity over and over again like you claim.

I will try to record a video with all those steps in orden to show it to you. I don’w know why but always it is the same. Do you know if there has been any update?

Hi, I recorded a video with all those steps. Would you like to see it? I don’t know if I can share this video here.