Installation Error, privilege for system services error

ZeroTier One service failed to start. Verify that you have sufficient privileges to run system services error.
I already tried group policy editor permission and restarting the device, trying to delete and download the installer again.

I’m having the same problem also, tried to edit group policy on window, doesnt help. I’m runnig window on a mac with bootcamp. Not sure if it is related.

I have same problem, Please help

I’m also having the same issue.

This is odd - all of the dates on the download page are from March 10.

1 Like

Seeing the exact same error here on a new Windows 10 PC. Tried to manually install the 1.8.5 msi file from the Releases page (March 10 date also), but failed.

I note that despite the timestamps, they are not the same file (different md5sums):
aae248e08c142b9a15ca672c7b85fd39 ZeroTierOne.msi
2b2a709c34994cf49a89b5f0e4917008 ZeroTierOne(1).msi

Running with logs captured: zerotier-one.1.8.6.log

Product: ZeroTier One – Error 1920. Service ‘ZeroTier One’ (ZeroTierOneService) failed to start. Verify that you have sufficient privileges to start system services.

MSI (s) (14:58) [18:06:17:953]: Note: 1: 1708
MSI (s) (14:58) [18:06:17:953]: Product: ZeroTier One – Installation failed.

MSI (s) (14:58) [18:06:17:953]: Windows Installer installed the product. Product Name: ZeroTier One. Product Version: 1.8.6. Product Language: 1033. Manufacturer: ZeroTier, Inc… Installation success or error status: 1603.

This may be poor etiquette, but I’m replying again with a workaround I found that worked for me:

It turned out that both version v1.8.6 and v1.8.5 would fail to install on a fresh Windows 10 Pro install. But… v1.8.4 did install. Please note I saw two .msi installers in the https://download.zerotier.com/RELEASES/1.8.4/dist/ folder. I’m not sure if I used the one with or without the space (%20) character.

After installing 1.8.4, I was able to upgrade to 1.8.6 as per normal.

2 Likes

This worked for me. Was pulling my hair out as I just did a clean install of windows and could not figure out why it wasnt working even though my user account was in the admin group.

I am having the same issue as well. Fresh install of Windows 10, fully updated.

Not sure what’s causing this one yet. I tried up & down today to get it to happen to me on a VM with a fresh Win10 install. Windows 10 x64 with all the latest updates. I tried installing on an Admin account as well as a “Standard” account & upgrading privileges to an Admin account. Both worked absolutely fine with the 1.8.6 installer from the website.

So what’s different in my setup? Are all your machines connected to MS ActiveDirectory/Domains? That’s the only thing I can think of that could be different here.

Hi zt-grant: Nope. I’m encountered the problem on a physical machine (not VM) running on a home network. No vLANS, no AD. Both 1.8.6 and 1.8.5 fail, but 1.8.4 installed fine.

Yeah I’m really not sure what’s happening. There’s nothing obvious that has changed in any code related to this between 1.8.4 and 1.8.5 either. Will take a look some more tomorrow, but I can’t promise I’ll find anything. (on a side note, MSI installers are the things nightmares are made of)

I was upgrading some machines from 1.4.6 to 1.8.6 and kept getting the same insufficient privileges error. As mentioned above, I tried installing the 1.8.4 and it worked. Then I was able to upgrade to the 1.8.6 just fine. This was on a Windows Server 2019 host, non-domain joined, no vlans. I also only tried the one WITHOUT the space in the file name on the 1.8.4.

I also noticed that the website was pulling from the 1.6.6 version instead of the latest 1.8.6. Not sure if that was intentional or not.

OK. Found the issue, and found out why I wasn’t seeing it as well: Because I installed Visual Studio on my VM before installing ZeroTier.

For some reason the installer isn’t installing the VC Runtime as it should and causes ZeroTier to just plain not work. Grab the latest VC Runtime Redistributable package from here. Just make sure you get the one marked X64 if you’re running a 64-bit system. After installing the VC package, the ZeroTier install will work.

Track the Issue Here on GitHub

1 Like

Hey zt-grant. Glad you tracked it down and thanks for the work on it.

Dependency hell - Twice in one week… I ran into something similar on Linux Mint last week with zerotier. Had to change my zt repositories to point at debian instead of ubuntu.

This worked for me too, thanks

We had to move hosting for the download site on 3/10. From the VM filesystem’s point of view, those files were created on 3/10, because that’s when they were put on the VM.

All of the installers are signed by our EV code signing certificate. You can see that the signing date didn’t change. If the file hash changed, the signature would no longer be valid. The file hashes didn’t change, the signature date didn’t change. Just the date the file changed on the filesystem because it’s a new VM.

Please stop spreading F.U.D.

Hi Guys,
I installed a fresh copy of win 11 and have the same issue mentioned here.
I manage to fix it by install vc_redist.x64 ( Visual C++ Redistributable for Visual Studio 2015)
then installed Zerotier Successfully. Hope it may help others.