Installation problem Debian 10 Buster

after entering “curl -s https://install.zerotier.com | sudo bash” nothing happens …
an empty command line appears, no error message
can someone help me?

What is returned if you just do curl -s https://install.zerotier.com?

after “curl -s https://install.zerotier.com” the same reaction as with “curl -s https://install.zerotier.com | sudo bash” no message, just an empty new line that corresponds to an input waiting.

Not sure what to tell you. Could be a DNS issue on your end. That server got moved to a new IP address over a week ago. Its TTL was 300 (5 minutes). Nothing should be caching it this long, but we already had another instance of that. Is there a difference in output if you do nslookup install.zerotier.com or nslookup install.zerotier.com 8.8.8.8? IP address should be one of: 35.244.247.201, or 2600:1901:0:ab1b::. If it’s anything other than that, something in your DNS path is caching things far too long.

with both variants:
-bash: nslookup: command not found

You probably need to install the dnsutils package, then.

thanks, I installed dnsutils

XXX~$ nslookup install.zerotier.com
Server: 127.0.0.53
Address: 127.0.0.53#53

Non-authoritative answer:
Name: install.zerotier.com
Address: 35.244.247.201
Name: install.zerotier.com
Address: 2600:1901:0:ab1b::

XXX:~$ nslookup install.zerotier.com 8.8.8.8
Server: 8.8.8.8
Address: 8.8.8.8#53

Non-authoritative answer:
Name: install.zerotier.com
Address: 35.244.247.201
Name: install.zerotier.com
Address: 2600:1901:0:ab1b::

Those are correct. install.zerotier.com is up, functioning normally and responding with the install script. I can’t tell you why you’re getting the response that you’re getting.

if you’re installing on a lxc container you will need to enable nested features keyctl and Nesting and you may have to enable a tun port as part of the setup. looks to me the install command returned nothing but may have installed the software but not recognizing the port.

how can I do it? I don’t know my way around that well

earlier the zerotier installation worked after i added curl and gnupg as well as the key 1657198823E52A61

yes having the ability to verify keys helps and curl is needed to run the script. Well done looks like your home .

I posted about lxc here Enabling Zerotier 6.4 Proxmox 6.4-4 LXC Containerw

I cannot find the lxc container under “sudo nano / etc /”. Could it be the prolem?

you may want to understand what it is first LXC: what is Linux Containers and how does it work? - IONOS

Install system Proxmon - VM Debian 10:

su

apt-get update && apt-get uprade
apt-get install -y apt-transport-https gnupg

curl -s 'https://raw.githubusercontent.com/zerotier/ZeroTierOne/master/doc/contact%40zerotier.com.gpg' | gpg --import && if z=$(curl -s 'https://install.zerotier.com/' | gpg); then echo "$z" | bash; fi

curl -s https://install.zerotier.com | sudo bash

curl -O https://s3-us-west-1.amazonaws.com/key-networks/deb/ztncui/1/x86_64/ztncui_0.7.1_amd64.deb

apt-get install ./ztncui_0.7.1_amd64.deb

sh -c "echo 'HTTPS_PORT=3443' > /opt/key-networks/ztncui/.env"
sh -c "echo 'NODE_ENV=production' >> /opt/key-networks/ztncui/.env"

systemctl restart ztncui

systemctl start zerotier-one
/sbin/zerotier-cli join XXXXXXXXXXXXXXXXXXXX
/sbin/zerotier-cli listnetworks

Tools
ip a
ip route

thanks, after the command:

“curl -s ‘https://raw.githubusercontent.com/zerotier/ZeroTierOne/master/doc/contact%40zerotier.com.gpg’ | gpg --import && if z=$(curl -s ‘https://install.zerotier.com/’ | gpg); then echo “$z” | bash; fi”

comes this message

gpg: no valid OpenPGP data found.
gpg: Total number processed: 0