IP is removed every time the network is rebooted in Ubunutu 20.04

Hi, I have a ZeroTier client on an OpenWRT router, several Android devices and a couple of laptops running KDE Neon (Ubuntu 20.04 derived). My problem occurs only on the Ubuntu derived laptops.

Every time I reboot the network, the ZeroTier interface loses its IP. I have tried to assign it manually, but again, when the network reboots, it’s gone. To restart the network I use the following command:
nmcli networking off && nmcli networking on

Once the ZeroTier interface has its IP everything works as intended.

Am I doing something wrong? Is there a known problem with a known solution or at least a workaround?

I don’t know if this is solved in another thread and would be grateful to be redirected if it is the case, I just can’t find any more useful information.


Hi, me again.

I had workaround it using the next command instead of previous one:
nmcli radio wifi off && nmcli radio wifi on

It worked to me because were laptops and the problem why I needed a command like this seems to be affecting only on wifi.

But still doesn’t understand why when I restart the networking the interface loses its IP while the others don’t.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.