Issue Streaming to iPad


I’m trying to stream a video stream to an iPad which is connected via ZT. The stream is normally viewed when typing an IP address (the server) and a port on a browser.

The streaming server is a linux box running latest version of ZT for Linux.

After the stream plays for about 20 seconds the stream stops. I have tried this with 2 different iPad at different locations/wifi connections, so the issue is not related to the wifi or router. The interesting thing is if I try to watch the stream on a Mac Book Pro (also using ZT) which is on the same wireless network as the iPads, I do not encounter any problems. This basically rules out any issues that might stem from the server side (and its router/switch/firewall).

I don’t know what can be the issue…

Any thoughts or pointers would be much appreciated.

Thank you


Oddly, if I run zerotier-cli peers

I get 13 entries when in fact I only have 9 members.

My MBP shows DIRECT whereas the Ipad shows -1 RELAY.

Not sure how this is possible given the MBP and iPad are on the same network and use the same WiFi.

I spoke to the people making the application for the video streaming… they said that there seems to be an issue with how WebSockets are implemented on iOS and iPadOS and its interaction with

WireGuard VPN seems to alleviate this issue apparently.

Not sure if anyone at ZT might know what the issue could be.

We get direct links on all our apple devices.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.