Join ok but no networks listed (attempt 2)

Hi. I’ve got a pi running the mainsail distro from the raspberry pi imager. It’s essentially normal raspian.

For a while now I’ve not been able to connect to this device over ZTO. It shows as connected to the ZTO network on the ZTO web portal and when I manually reconnect it via zerotier-cli I get 200 join ok.

Even so, I see no ZTO ip in ifconfig and there are no networks listed when I run zerotier-cli listnetworks none are shown.

I’ve tried reinstalling ZTO and leaving and joining, updating everything else, rebooting, but still no luck.

Can anyone suggest additional troubleshooting steps? Thanks!

does /dev/net/tun exist? If not, you’ll need to get the TUN/TAP module loaded in the linux kernel, likely via sudo modprobe tun

Bingo! Thanks. That path didn’t exist, and running sudo modprobe tun did it. I’ve now added tun on a new line to /etc/modules to fix this permanently however I did check and see this wasn’t present on other machines with a similar config that do work. If there are other ways to enable this on boot, perhaps I should use those.