Mac OS Big Sur compatibility

I see several notes about compatibility with Big Sur and ancient versions of ZT.

I am using 1.6.2 and just upgraded my laptop to Big Sur, and suddenly I cannot access devices across the ZT plane. My client shows online, but I can’t so much as ping.

My ZT network is still up, because I can access devices using my Ubuntu laptop.

mac:~ > sudo zerotier-cli info
200 info b4a984062a 1.6.2 ONLINE
mac:~ > ping
PING ( 56 data bytes
Request timeout for icmp_seq 0
Request timeout for icmp_seq 1
Request timeout for icmp_seq 2
Request timeout for icmp_seq 3
Request timeout for icmp_seq 4
--- ping statistics ---
6 packets transmitted, 0 packets received, 100.0% packet loss


Just to double check, you were already on ZeroTier 1.6.2, and upgraded your mac to Big Sur?

Can you try sudo systemctl restart zerotier-one on your ubuntu laptop and see if the mac starts talking with it again?

The linux machines have their auto updates run pretty regularly, so they were 1.6.2 almost right away. The mac was updated to 1.6.2 just after the OS upgrade (yesterday).

The device(s) have been rebooted several times since then. I run 3 ubuntu based servers (2x 20.04, 1x18.04), 1 centos server, 3 raspbian buster devices, an ubuntu raspberry pi device (20.10), one windows device, one ubuntu laptop (18.04), and the mac on ZT.

Only the windows machine is still running an old version of ZT (1.2 I think, because I’m too lazy to muck with windows).

Only the mac (newly updated to Big Sur) has issues.

ubuntu laptop => servers :white_check_mark:
ubuntu laptop => raspberry pi devices :white_check_mark:
servers => servers :white_check_mark:
raspberry pi => servers :white_check_mark:
windows => raspberry pi :white_check_mark:
mac => anything :x:

I love ZT. It’s a crazy easy way to access stuff across different networks, behind NATs, and (in the case of the servers) to turn off SSH access to the public interfaces and harden the machines. But this OS update borked the mac. :frowning:

After rebooting my mac again, it started working. Must have been something residual in the initial driver loads.

Anyway, fixed now.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.