Machine connected but unreachable

I’ve set up zerotier on my homelab proxmox 8 machine. I changed the name of the device to enp1z0 through /var/lib/zerotier-one/devicemap. Then I added the following to /etc/network/interfaces

iface enp1z0 inet manual
        mtu 2800

After that the interface appears on the proxmox gui and I created a bridge to it and gave it the ip, which is the same as the one declared on the zerotier control panel.

Then on any VM or CT I can create an interface, connect it to my zerotier bridge, give an ip in the range and it gets added to the network.

This worked fine until yesterday. I set up a CT, spend hours trying to get gdrive mounted and once I’m done, I try it out and I realise that I cannot reach anything on the proxmox machine (and the mechine itself). I have no clue what changed and I have no clue how to debug this.

The proxmox machine is connected to the control panel. I even upgraded from 1.12.0 to 1.12.1 and the version changed online. The state of enp1z0 comes up as unknown and it cannot find any route to any other machine (it can still reach its VMs and CTs). I deleted the peers and restarted everything, but to no avail.

Do you have any suggestions?

I managed to solve it. This is my proxmod network tab of the host machine:

This looked correct, but I realized with ifconfig that enp1z0 was given the ip I have no clue why. I made a small change on the networking tab just so that it gets applied again (changing a comment is enough) and then it worked, entp1z0 didn’t have an ip anymore.

The problem now is that I don’t understand why this happened. Has this happened to anyone else? I would like to figure it out because if it happens when I’m away, I’ll get locked out of my system. Any ideas are welcome.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.