Missing nodes on a single client

I have a couple of nodes consisting of an iPhone, 2 Linux servers, a PC running Windows 11 and now a MacBook running MacOS Ventura.

When connecting the Mac to the Zerotier network (and authorizing the new node) all the peers display correctly when running sudo zerotier-cli peers, except the 2 Linux servers. When running the same command on both of the servers, all of the peers show except the Mac.

Running 1.10.4 on the Mac, and have tried downgrading to 1.10.2 as well. Have cleared the identity multiple times and reinstalled multiple times to no avail. The firewall on MacOS is turned off.

zerotier-cli peers is not a list of network members. It’s a list of other machines running zerotier that the node has communicated with recently. If the Mac hasn’t connected/spoken to the nodes running Linux over the zerotier network, there’s no reason that it would be in the peer list.

Thanks for the quick reply. When pinging the assigned address from the Mac, the response is a timeout. When pinging the same device from the Windows machine, it responds just fine, with them both sitting on the same subnet (172.22.2.x).

Is there a way to debug this issue using zerotier?

Okay, nevermind? I just got it to work with the fifth (?) reset. Running the dump and searching for the server adress showed a result, and pinging afterwards got a response. Weird, thanks for the support.

The connection between the two network members worked yesterday evening, and stopped working again today. Another reset did not fix the problem. Is there any way to debug what is preventing communication between the two network members?