Multicast Problem

hello,

first of all I would like to apologize for my English.
The second apology for the fact that I may be posting in the wrong category.

But now to my question.
I have a Debian server which acts as a bridge in my network. unicast communication works without problems.
now i wanted to do a small audio streaming test and configured igmp snooping and a querier on my switch, which is in the ZT LAN directly connected to the bridge.
now I would like to provide a multicast stream from my ZT Lan (behind the bridge) in the network. but unfortunately it does not arrive.

so I tried to make a small test with iperf.
if i now
iperf -s -u -B 225.1.2.3% -i 1 on the sender side (from my ZT LAN behind the ZT Birdge), data is happily sent, but on my client (linux pc) i can join the group but get no data packets.
am i doing something wrong, do i need to create special network rules or maybe even change the local.conf on the bridg and the client?

EDIT: one more infomration, inside my ZT LAN (Behind the ZT Brigde) it is working of course!

I appreciate any advice
greetings marco

hello,
there was an issue with multicast on 1.8.1. Is that the version you are on? There should be zerotier updates available if so.

running on both ends version 1.8.2…
is there any special rule to allow brodcast and mcast traffice?

ok!
solved by myself, thanks anyway! :smiley:

Great! How did you do it?

for whatever reason, a static route of the mcast group address to the dev zt interface solved it.
i guess the join and leave requests don’t reach the querier and therefore the switch doesn’t forward anything- even if the mcast group and the trafic should be omnipresent, because the connection from my switch over the zt bridge is like a trunk into the zt netwezrk, right?
is zerotier not a real VXLAN?
do you have experience with igmp snooping and joins and leaves?
would be interesting to know?

Thanks.
It’s supposed to Just Work. It did in the past. We’ll figure it out in the next release.

hey travis,

thanks a lot!

Hello.

Is this resolved in 1.8.3?

Thanks!

Hello,
1.8.3 sets the multicast flag now, but there are still reports of multicast not working which we are looking in to.

I’m testing with avahi-daemon and avahi-browse 1.8.3 and it seems to work.
If anyone has an example that was working on 1.6 and isn’t on 1.8 let us know!

hello gentlemen,

I will test the version tomorrow and report.

Travis,

have you used dnssd or plain mdns in your avahi config?

Not sure. I just used the defaults and set publish-workstation=yes

publish-workstation= Takes a boolean value (“yes” or “no”). If set to “yes” avahi-daemon will register a service of type
“_workstation._tcp” on the local LAN. This might be useful for administrative purposes (i.e. browse for all PCs on the LAN),
but is not required or recommended by any specification. Newer MacOS X releases register a service of this type. Defaults to
“no”.