My machine can't host servers, but can join them

I installed ZeroTier One today as it was promoted as a superior alternative to Hamachi (which it has proven to be, with greater speed and reliability as far as I can tell). However, I’ve run into a peculiar problem.

When trying to run a game of OpenTTD, I was not able to host a game. The unusual part is that my friends could, and I could join their games. The issue was specifically me hosting a server. We narrowed down the problem to my machine, as each member of the network successfully hosted a server others and myself could join. We thought that perhaps the issue was that I was the network owner, and that prevented me from hosting. So my friend made his own network, had me join, and once again I couldn’t create a server but he could.

I have tried reinstalling both applications (OpenTTD and ZeroTier), and I allowed them both through the firewall on both private and public connections. In the ZeroTier network settings, I enabled ‘Allow Global IP’, ‘Allow Managed IP’, ‘Allow Default Route’ and ‘Allow DNS’, which didn’t help the situation.

If anybody has any suggestions or is willing to walk me through the debugging process, I would be delighted to listen. This software has worked flawlessly thus far and it would be a shame if I had to switch out because of this issue.

Thanks in advance.

I do not have a solution for you, to make it easier for someone who might have a solution, could you tell us which OS and ZeroTier version you are using?

I’m using ZeroTier One version 1.6.2, OS is Windows 10.

I managed to fix it myself. The issue was the program incorrectly installing, I solved it by uninstalling and running the program as administrator. Cheers.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.