NAT and portmapping


When a ZeroTier node connects to the root servers they learn the public IP and source port of the node. That IP address and source port is then distributet to other nodes in the same network. Is it there some setting in local.conf that will allow me to override this with another port?

My nodes are at two different locations behind firewalls. I have portmapped udp/9993, udp/9994, udp/9995 from internet to both nodes and i created a local.conf file with the following configuration.

“settings”: {

My problem is that the firewalls do not use source port 999x for outbound connections when the sourceport on the inside is 999x. The port is random for every connection and all other nodes try to use that port when creating peer-to-peer connections.

Any ideas?

This topic was automatically closed after 30 days. New replies are no longer allowed.