Need For Speed Most Wanted can't connect

Using ZeroTier we can create a server and we can see the created servers. When we are trying to connect we are having a timeout issue.

Without a ZeroTier in a real LAN network the game is works well so the game versions or firewall settings are okay.

Hi,

Do you mean ZeroTier? We didn’t write Zscaler, nor do we have anything to do with it.

Sorry for the mistake, ofcourse ZeroTier.

Well it can still very well be the firewall. Windows Firewall works on a per-network-interface basis. ZeroTier shows up to your system as its very own network interface and will have its very own Windows Firewall rules, and may also be set to “Public” which is a more restrictive setting.

You can try opening an Administrator PowerShell prompt and issuing this command to set the network to “Private” and see if it helps. Otherwise, you might have to dig further into the Windows Firewall settings.

Get-NetConnectionProfile | Where-Object "InterfaceAlias" -like "Zero*" | Set-NetConnectionProfile -NetworkCategory Private

I have executed the following in PowerShell as administrator:
Get-NetConnectionProfile | Where-Object “InterfaceAlias” -like “Zero*” | Set-NetConnectionProfile -NetworkCategory Private ;
and I also set the ZeroTier network controller to the first adapter with:
Get-NetIPInterface | Where-Object “InterfaceAlias” -like “Zero*” | Where-Object “AddressFamily” -eq “IPv4” | Set-NetIPInterface -InterfaceMetric 1;
I tried to disable the whole windows firewall, but it still not working. :frowning:
Thank you for the support!