Network issues with no idea how to narrow down or troubleshoot

I’m extremely frustrated by the lack of diagnostic tools or information available by the client and GUI. I would happily pay for support but ZeroTier fails to offer that.

I have a ZeroTier network that I setup initially to test if ZeroTier would work for my devices. Call it NetworkOne.

NetworkOne had a QNAP host on Frontier ISP.
NetworkOne had a MacBookPro on T-Mobile ISP
NetworkOne had a Windows laptop on Xfinity ISP.

Window laptop could connect to MacBookPro.
MacBookPro could connect to QNAP host
Windows laptop could not connect to QNAP host.

This resulted in the lunacy of me having to VNC into my MacBookPro from my Windows laptop in order to interact with the QNAP host. I was unable to troubleshoot or diagnose the problem.

Frustrated, I created a new network with a new email called NetworkTwo and eliminated the ISP connection that was being problematic.

NetworkTwo has the QNAP host on T-Mobile ISP.
NetworkTwo has MacBookPro and Windows laptop on Xfinity ISP.

None of the devices can connect to each other on 172.28.x.x range.
The Mac and Windows laptops can connect to each other using 10.0.x.x addressing provided by Xfinity router.
Neither can connect to the QNAP host.

Looking at ZeroTier Central, all three devices show up as online, 1.10.1 (QNAP) or 1.10.2 version. Everything appears fine.

How can I troubleshoot this? From both laptops, ping says destination unreachable. Traceroute says No route to host.

I have reinstalled, changed IPs, tried options like Allow Default Router Override and nothing is working. I cannot understand why this worked (albeit with issues) previously and now it doesn’t work at all when I did everything the same (except using the newer versions of the client).

It seems like ZeroTier for whatever reason is not answering calls for 172.28.x.x IP addresses, and consequently the devices are trying to route private IPs over the ISP connection which obviously drops them. I don’t know how to force anything starting with 172 to go over the ZeroTier network adapter. I tried using the route command from Administrative Cmd to force that rule but it had no change.

I have googled every possible combination of troubleshooting steps, process, how-to, guide… nothing tells me what I to type into the command line to identify WHY I am unable to route to ZeroTier IPs when clearly they are all able to talk just fine to the ZeroTier server.

Windows 10, MacOS 10.14.6, QNAP 5.0.1

Thanks.