New connection issues with Synology SPK

I have a Synology running at 2 different sites with V1.4.0 SPK package installed on both. I continue to use this version because these two machines will not be upgraded DSM7. I run ZT V1.8.4 in an Ubuntu VM at home which allows me to connect to the remove network for administration, etc. This has been running for a very long time with no issue. I’m using ZT’s server.

At one site, I lost connectivity at midnight and 12 hours later still have no connectivity. The Synology ZT app shows OFFLINE, but status is OK and it gets a private IP from ZT. On my ZT web status page it shows this node as ONLINE, but I’m unable to ping its IP from my local ZT VM. I’ve tried deleting and adding back the NODE ID but it results in the same status.

On the 2nd site, connectivity is still good, but the Synology APP also shows OFFLINE. I’m wary about messing with it too much in case it results in loss of connectivity.

Did something happen on ZT’s side at midnight to cause this? How do I go about troubleshooting this further?


Nothing has happened or changed on our end in the time period you’re speaking of.

I tried deleting identity.public and identity.secret to get the ZT app to create new node ID. I added the new node and now the app shows ONLINE on the Synology ZT app. However I still have no connectivity. Yes the IP address changed, but I modified the ZT managed routes appropriately.

I’m out of ideas. Got any suggestions to debug this?


I managed to get it working again, but not sure what did it. I updated my local zerotier running on Ubuntu from 1.8.4 to 1.8.5 and now everything is working again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.