No connectivity when switching to backup ISP

Hello all,

I’m having an issue where if my router switches to my failover ISP, zerotier doesn’t seem to reconnect ever. The only way to get connected again is for the primary ISP to come back online or if I manage to SSH in via the external IP and service zerotier-one restart on all servers running zerotier.

Any idea of how I can make this more seamless as it kinda defeats the purpose of a backup connection like this?

1 Like

So, Multipath wasn’t designed for this exact use case (more so where you have two active links presented to ZT), but you could try using active-backup in your local.conf like so:

{
  "settings":
  {
    "defaultBondingPolicy": "custom-active-backup",
    "policies":
    {
      "custom-active-backup":
      {
        "basePolicy": "active-backup",
        "failoverInterval": 10000
      }
    }
  }
}

This will increase ambient traffic (to measure links) but it should cause a faster switch to your new link.

Let me know if you have any other questions on this.

EDIT: Fixed typo in example

I don’t see a local.conf. Are you referring to the {networkid}.local.conf file? That doesn’t seem to be a json file though.

By default it doesn’t exist, you need to create one in your ZT installation’s home directory. Usually /var/lib/zerotier-one/ on something like Linux.

Putting this in my conf seemed to completely break zt.

Sorry. My example had a typo in it. Fixed.

I accidentally left out the policies section as well. This works on my machine:

{
  "settings":
  {
    "defaultBondingPolicy": "custom-active-backup",
    "policies":
    {
      "custom-active-backup":
      {
        "basePolicy": "active-backup",
        "failoverInterval": 10000
      }
    }
  }
}

Decreasing the failoverInterval will improve ISP switching speed but will increase overall traffic overhead.

Ok this one doesn’t seem to break it, I’ll have to wait until later tonight to test it out and make sure it switches when the primary ISP fails.

Worked great. Thanks @zt-joseph

Glad to hear. Just watch the data usage if you’re on an expensive link.