Ping results in destination host unreachable after update (I guess?)

Now first and foremost, I’d like to say that I tried to google (even went to the second page) and I did found people with similar problem but none of the solutions provided didn’t help. Now to the problem at hand.

I’ve had some issues with connectivity to one of the PCs, ping went through but I couldn’t discover my main pc from it. So I decided to update from 1.4.6 to 1.6.4. Things worked for like 20 minutes and suddenly it stopped. Now I can’t even ping any of the PCs, I usually get “destination host unreachable” for first reply and then time outs only. I’m getting very frustrated, so I’d welcome any help.

Things I tried:

  • Clean Install (Like 10 times already, I’m not sure how clean it is, because I still have the previous networks visible in ZT).
  • Roll back to 1.4.6
  • Port forward (which I didn’t need before)
  • Check listnetwork and listpeers on CLI, network shows OK, peers show LEAF plane
  • Creating new network
  • Disable firewall

I might have forgotten something from what I tried, I’ve been trying to fix it nonstop since yesterday. Anyways, any help would be greatly appreciated, thank you.

Edit/Update: I can now, for a reason unknown to me, ping some™ devices on other network, but the main network in question is still unresponsive. Really gives me the idea that the problem is on the other side than mine pc, but again, the main PC can’t connect to the others, while two others can ping each other. Weird…