Problem mit IPv6 Routing using Zerotier Central for Assigment


i use Zerotier for some time to distribute ipv6 access on my devices. In the past i had issues assigning global IPv6 Adresses because i didnt know about “allowGlobal”. So i used radvd for ip and route distribution. Sometimes radvd ist quiet slow and it takes up to 10 min. for clients to pickup an ipv6 so i searched how to use Zerotier Central to assign IPv6 IPs and found that i need AllowGlobal and allowDefault.

Today i renumbered my Subnet and i give Zerotier clients IPv6 adresses, set route for ::0/0 to my Router and set allowglobal and allowdefault on all my clients, so far no success. Clients get IPv6 IPs but a non working route. I compared the routes from my new and my old radvd apporach and found out that the default route has to be the fe80:… of the Router, so i put that in Zerotier Central as route for ::0/0 but no success, it doesnt get distributed to the zerotier clients :frowning:

Settings route by hand after starting zerotier with ip -6 route add default via fe80:… (ip of my router) dev zt… works, clients can now reach the internet via ipv6.

Is this approach wrong? how is the correct way to distribute ipv6 routes to zerotier clients?

This topic was automatically closed after 14 days. New replies are no longer allowed.