Proxmox Bridge on CT zerotier-cli listnetworks empty

I’m trying to set up a zerotier client as a bridge to the LAN according to

I create a CT container on Proxmox with Linux zerotier 6.2.16-4-pve #1 SMP PREEMPT_DYNAMIC PVE 6.2.16-5 (2023-07-14T17:53Z) x86_64 (I also tried with Ubuntu),
I install the Zerotier client and connect using the command

root@zerotier:~# zerotier-cli join $NETWORK_ID
200 join OK

In the panel at ZeroTier Central, I authorized the client with a checkbox.

Unfortunately in the next step:

root@zerotier:~# zerotier-cli listnetworks
200 listnetworks

I receive an empty list and I have no clue how to proceed further.

I’m looking online, but nowhere is a case of listnetworks being empty.

I will add that the status returns ONLINE

root@zerotier:~# zerotier-cli status
200 info xxxxxxxxxx 1.12.2 ONLINE
I’m new to ZeroTier. Why is the list empty?

I will also add network interfaces in the CT machine.

root@zerotier:~# ifconfig
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet netmask broadcast
inet6 fe80::8c9f:1bff:fefa:96d1 prefixlen 64 scopeid 0x20
ether 8e:9f:1b:fa:96:d1 txqueuelen 1000 (Ethernet)
RX packets 3535 bytes 12805864 (12.2 MiB)
RX errors 0 dropped 147 overruns 0 frame 0
TX packets 2379 bytes 198159 (193.5 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet netmask
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 60 bytes 4885 (4.7 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 60 bytes 4885 (4.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

It seems that even though I am connecting to the network and the status is “joined OK”, a dedicated network interface is not being created. Maybe it’s a problem with CT permissions?

I tried with a privileged container and the effect was the same: Joined OK, but listnetworks is empty… :frowning:

I’m making some progress, but it’s a brute force solution. Maybe it will be useful to someone if this issue can’t be solved more elegantly.

A partial workaround for me was to create a full-fledged Virtual Machine with Debian 12 in proxmox. On this machine, after joining the zerotier network, an additional ZT network interface was created and displayed with the listnetworks command. It was also visible in ifconfig.

However, still it would be nice to implement the same functionality in a container (Proxmox CT), without the additional overhead on RAM and other resources.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.