QNAP - Failed to install ZeroTier. Downgrade QTS to 5.0.0 or an older compatible version

Hi guys,
Firstly - i LOVE zerotier and I only learnt about it last night.
I have installed it on a few machines with different OS’s - all good.
I installed it a QNAP TS-453b with firmware QTS 5.0.1.2145 Build 20220903 without issues and connected.
I then went to install it on a QNAP TS-453pro with same firmware and it would not install with the error message: Failed to install ZeroTier. Downgrade QTS to 5.0.0 or an older compatible version

I have read the single thread here about this issue but what I don’t get is that it works on one unit but not the other- near same hardware and exactly the same firmware?

Is there anything we can learn from this?

I really don’t want to mess around with dockers to make it work as that defeats the benefits and my view of the zerotier.
Anyway, just thought I would share that info incase there is something there to learn from - I am happy to dig deeper with guidance.
GREAT work developers - love it and so surprised I did not learn about it till last night
Br MC

3 Likes

I just upgraded to the latest update on a similar x64 QNAP, rebooted and now Zerotier will not work.
Removing Zerotier as it was greyed out, I tried reinstalling it and have the exact same problem.

Likewise in the logs…

Failed to install ZeroTier. Downgrade QTS to 5.0.0 or an older compatible version

Any help would be greatful

3 Likes

The same problem!!! Any help! Thanks!

2 Likes

The same problem! Please help! Thanks!

2 Likes

Same here… looking forward to any updates on this. Love ZeroTier!

1 Like

busy thread guys :slight_smile:

Of course all QNAP users should upgrade firmware to protect against DeadBolt which is causing destruction atm.

BIG thanks in advance for functional update for QNAP users and have a restful weekend.

MC

I also have the same problem after updating to QTS 5.0.1.2145 :bangbang:
My NAS model: TS-332X

I also have the same problem after updating to QTS 5.0.1.2145 :bangbang:
My NAS model: TS-251+.
Hoping for a quick update, I need the Zerotier Network

Brgds Martin

Detto. Please update the QNAP packages.

Same, can’t install payed software (30 EUR) on my QNAP NAS TS-231P2 after QTS 5.0.1.2145 update.

[App Center] Failed to install rtorrent-Pro. Downgrade QTS to 5.0.0 or an older compatible version.

Would be nice to get this corrected. Anyway, thanks.

I have the same problem, to see if it could be solved, thank you very much.

this is accurate information. Zerotier with QTS 5.0.0 or QuTS 5.0.0 works perfectly. Once an update is done to QuTS 5.0.1 or QTS 5.0.1, Zerotier no longer works.

This was posted as a fix, but the description is not clear to me, and I have not been able to get this to work - (my stupidity, and too brief of an explanation) -
hi this is simpler and better and works (only x64 cant test others)
use docker first install QVPN for the tun driver

docker run -d --name zerotier-one --device=/dev/net/tun --net=host --cap-add=NET_ADMIN --cap-add=SYS_ADMIN -v $HOME/docker/zerotier-one:/var/lib/zerotier-one --restart=always zyclonite/zerotier

docker exec zerotier-one zerotier-cli join 8056c2e21c000001

or create an empty file with the network as name
/var/lib/zerotier-one/networks.d/8056c2e21c000001.conf

I think I prefer to protect myself from DeadBolt at this stage - the firmware update is important given the risks - IMHO.

Hi marqueMC - the whole point of Zerotier is to be able to VPN into your QNAP without opening up any ports on your internet router. If you don’t open up any ports on your internet router (and use Zerotier for VPN) - then there is no risk of Ransomware like Deadbolt or QLocker. This is why I am anxious for this to be addressed.

1 Like

Hello -
I was excited to post a new “fix” for Zerotier and QTS 5.0.1, but it appears to not be working.
This is new at QNAPClub

you download the package, and manually install it in The QNAP App Center. This installs Zerotier 1.10.1. It certainly appears to install properly, and light up “yellow/orange” in the App center. But now, when you ssh into The QNAP, so you can activate this with your Zerotier Network ID -
no matter what command you type in, in terminal - for example
Zerotier-cli -v
Zerotier-cli -h
zerotier-cli join NetworkIDNumber

you get the same error in terminal -
-sh: Zerotier-cli: command not found

perhaps of of you guys can try this.
thanks !

Thanks Bobzelin for the efforts

I installed the package and it did install no problems.
After I SSH’ed into the QNAP NAS I could find the installed files here - /opt/0Tier1/
and the exec file here - /opt/0Tier1/var/lib/zerotier-one/zerotier-cli

Tried many ways to launch zerotier-cli but I noticed…

lrwxrwxrwx 1 admin administrators 22 2022-09-22 00:35 zerotier-cli → /usr/sbin/zerotier-one
lrwxrwxrwx 1 admin administrators 22 2022-09-22 00:35 zerotier-idtool → /usr/sbin/zerotier-one
lrwxrwxrwx 1 admin administrators 22 2022-09-22 00:35 zerotier-one → /usr/sbin/zerotier-one
-rw-r–r-- 1 admin administrators 276 2022-06-28 20:46 zerotier-one.te

Which leads me to think maybe the zerotier-cli is not correctly copied?
Maybe I’m missing something but after installing it on a RaspberryPI today, I remember there being 3 different exec’s?

By the way I tried ./zerotier.one from different directories within /opt/0Tier1/ but nothing worked for me.
Will have a longer look tomorrow when I got time, otherwise I’m going to try tailscale.

I am replying only because I do not want ZeroTier to close this thread. Wonderful people like Cubicgarden, and marqueMC have been very active in addressing this issue. QNAP QTS 5.0.1 is not working with the ZeroTier 1.8.4 “official version” or the 1.10.1 version that can be found on the QNAPClub website. I hope that someone at Zerotier takes note of this. I have seen somewhere else that someone wrote - “just run it in a VM” - this is NOT an acceptable answer. It should work, just like it was running before, with QTS 5.0.0.

Thank you all for your participation. You are all great.
Bob Zelin

Thank you bobzelin, I’m confident zerotier will fix it but when is the question.
I just happen to be traveling quite a bit in the next month and VPN access to the NAS is essential (especially with ransomware everywhere).

I still have Zerotier installed on all my machines including Android devices but installed Tailscale on everything except my Raspberrypi’s (couldn’t get it working).

The longer I use Tailscale, the more chance I’ll stop using Zerotier.
I guess I wasn’t paying for Zerotier but may have considered it later once I hit the free limits.

Hey guys, if you have the package still installed, you can enable and start the service manually:

CONF=/etc/config/qpkg.conf
QPKG_NAME="zerotier"
QPKG_ROOT=`/sbin/getcfg $QPKG_NAME Install_Path -f ${CONF}`
/sbin/setcfg $QPKG_NAME Enable TRUE -f $CONF
/share/CACHEDEV1_DATA/.qpkg/zerotier/zerotier.sh start
zerotier-cli status

QTS disables it again on reboot, so you’ll have to log in and start it manually.

Cheers,
–Martin

Hi Martin -
thank you for your hard work on this, but this is not working.
I will explain in detail.
I have QTS 5.0.1 installed on a QNAP TS-251+ test system, which is an x86_64 system.
With Zerotier 1.8.4 installed and QTS 5.0.0, Zerotier worked perfectly ( I retested it again yesterday).
I go to

and manually install Zerotier 1.10.1_x86_64.qpkg
It installs and “appears” to be running, but when you ssh into The QNAP all commands come back
with “zerotier-cli: command mount found”

I was more than anxious to test your fix this morning.
Again, I am running QTS 5.0.1 on a TS-251+ with Zerotier 1.10.1
I ssh into The QNAP, and one by one, enter the commands that you have shown us.
once we get to
/share/CACHEDEV1_DATA/.qpkg/zerotier/zerotier.sh start
it returns -
“No such file or directory”
so this is NOT starting Zerotier, and of course, any Zerotier-cli commands entered
after that return “command not found”.

Thank you for your hard work, but it’s still not working.

Bob Zelin