Relay connection problem

Hello guys i wanted to connect to my friend and play minecraft together with zerotier but there is a problem
my friend and i can’t get a direct connection and that is a pain be cause we can’t really play with 600ms ping or 300ms ping
i establish a direct connection with all of my friends normally except this one
things i tried:
tried going into his firewall setting in his computer he had rules so that was not the issue
went into his router to see if UPNP is on it was on
and that’s about it i went over other issues in this website and i saw someone say “it doesn’t accept udp connections” maybe that’s the issue? but i dont exactly know how to make the router accept udp

also as a sidenote he did establish a direct connection to one of my friends but i think it’s be cause of the nat type of his internet

so what do you guys say? i’m open to try anything at this point i dont know what’s the problem that’s causing him to not direct connect if you guys know any solutions or any possible fixes please let me know
thanks in advance

Maybe check this concerning the UDP part:

https://docs.zerotier.com/routertips#is-my-device-relaying

The “TCP fallback” part seems important. That would at least answer one question.

You might need to provide some more details about the router in question and your friend’s ISP. These days lots of ISPs provide both a CG-NAT IPv4 address and a public IPv6 address block. The CG-NAT address means being stuck behind double NAT once you add a home router, which ZeroTier doesn’t like. But using IPv6 gets around that, if it’s available.

thank you for the reply!
well about the tcp fallback

for mine it’s:
“allowTcpFallbackRelay”: true,
“forceTcpRelay”: false,
“tcpFallbackActive”: false,
for my friend
“allowTcpFallbackRelay”: true,
“forceTcpRelay”: false,
“tcpFallbackActive”: false,

my friend’s modem is “tp link w8961n”
unfortunately my knowledge is very limited when it comes to CG-NAT how do i know if he is behind a CG NAT?
and about the ISP, it is offering them wireless internet and that’s about all i know
i’ll search for how to check for CGNAT
thank you Again for the reply.

EDIT: i did some research on it and i think we both might have CG nat internet everytime i tried to portforwarding it didn’t actually forward it and my pc itself doesn’t have a valid public ipv4 so i think i’m behind a cgnat address well how do i use ipv6?i tried the website http://test-ipv6.com/ and it appears i don’t have a ipv6 despite having a cgnat internet

I’m not an expert on this, so I’ll stick with the parts that I know and maybe someone else can chime in to fill the gaps. You might also need to reach out to either your ISPs tech support or a more general community forum as far as figuring out IPv6 setup in general.

It’s not guaranteed that you get IPv6 from the ISP, regardless of whether they use CG-NAT for IPv4. Some offer it, some don’t.

My first step would be to log into the router check if it’s configured for “dual-stack” IPv4/IPv6. That should be on the “Interface Setup” → “Internet” page of the WebUI. If it’s set only to IPv4, then the router wouldn’t see any IPv6 address even if the ISP offers it. I’m assuming you’ll need to reboot the router if you change that setting.

Once it’s in IPv4/IPv6 mode, I think the “Status” page should show whatever WAN/internet address(es) your ISP is providing. If an IPv6 address doesn’t show up there, then you might be out of luck. You’d have to contact your ISP’s technical support for more information.

If you do see an IPv6 address there, then you still need to make sure that your computer is set up for IPv6. This part I can’t really help with because I only ever use IPv4 on my PCs. I think Windows 10 and up is generally IPv6-ready out of the box, but I don’t know that for sure. It should be a reasonably easy topic to find search for help with elsewhere.

I wish I could be of more direct help.

1 Like

hello and thank you for help you helped me immensely by introducing me to CG NAT i didn’t know what it was and i’m definitely behind cgnat i was in my WAN options and i saw ipv4 then i googled my ip and it wasn’t the same so i’m behind CG NAT
and i contacted my ISP and talked about it they didn’t know what it was probably be cause english isn’t their main language, so i asked them if i buy this “static ip” will that get me out of cg nat and they didn’t really answer me and i also asked them about IPv6 and to my luck they didn’t even answer me about it not a good customer experience xD
dual stack mode i can’t see it in the modem is it in WAN?

i fixed it by buying a static ip it seems that did the job and now i am out of cg nat hell and can finally get solid ping 30 ms once again sir you helped so much thank you

I think you mostly figured this out yourself; I didn’t help much.

Paying for a static IPv4 address is definitely a simpler way to get around the problem, and if you don’t mind the extra expense, you’re all set.

In case you come back to this in the future:

When I looked at a PDF manual for that router, it showed the setting for IPv4 or IPv4/IPv6 or IPv6 in the third “section” of the “Interface Setup” → “Internet” page of the WebUI.

“IPv4” would mean IPv4 only, “IPv4/IPv6” would mean both (a.k.a. “dual stack”), and “IPv6” would mean IPv6 only.

1 Like