Remote Desktop iOS client cannot connect to Win10 PC, but a different Win10 PC can

I’m not sure if the problem is on the Windows side or the iOS side.

I have one Zerotier network, set up with two PCs and an iOS device.

I have tested connecting both ways between the two PCs. Both have ZeroTier installed, and I am able to connect with RDP. Both PCs have been tested on the same home network, but I have not moved one of them off the network to test if it still works.

After having trouble getting the iOS device’s IP to show up in my network management, I got it to work.

On the iPhone, I have “default connection” and “on demand” turned on in the ZT app, and I confirm that I am connected in the iOS Settings, VPN section.

I open the iOS Remote Desktop app, enter one of the PC’s Managed IPs into an entry for a new PC (not a new Workspace), save, and click connect. I get an error that the device could not be reached, error 0x204.

I have marked the ZT network interface as Private on the PC I am trying to connect to, but this did not solve the issue.

The iPhone is on the same wifi network as the two PCs, and is also on LTE. The address shown in iOS Settings, VPN, ZT, is the correct Managed IP given in the ZT Network administration page.

What have I missed? What can I try?

Thanks.

Update: I have tested connecting from the phone to the PC using the non-ZT 192.168.x.x IP given out by my router, with both devices on my home network. RDP worked with no issues.

I therefore think this is more of a ZT-on-iOS issue than an RDP issue.