Required zt network interface not create at install (Linux Mint 21)

I have a Linux mint 21 running on a dell optiplex 3060 (i think that’s the right numbers) and I installed Zero tier using the curl command that download and runs a script to add the repo and then install

That all went well and the service is active and running but it did not create a new network interface to use

i have searched and found a few mentions of this from 2020 and version 1.6 but I have the latest 1.10.6

I have tried some things that were mentioned liking making sure /dev/net/tun was there and I followed instructions to create a tun interface and that worked ( i believe that is how zerotier adds the interface)

I have update the system purged the zerotier-one and then reinstalled and nothing

I have added the machine to my network on the web page but with out the interface its obvioulsy not connecting

I have two other Linux mint 21 (MATE) computers on which it is working perfectly

Any ideas on how to fix this?



Ok Doing a reply to my own post as i solved the “problem” I probably had not read the installation instructions although I am surprised I was not finding anything during my hours of searching - but the issue was that I had not joined the client to a network. I found this out by installing zerotier to a VM and seeing it had the same issue then i tried the cli join and then suddenly the ZT interface was configure and it got an ip address - so I hope this answer could help other who were as lost as me

Sorry about that. You can join multiple zerotier networks. Each network gets its own interface.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.